0%

alacritty のバージョンをアップデートした際のWarning対処

alacritty のバージョンを 0.3.0 から 0.4.1 あげた際の Warning の解決方法。

Warning

1
[2020-01-10 10:49] [WARN] Config scrolling.faux_multiplier is deprecated; the alternate scroll escape can now be used to disable it and `scrolling.multiplier` controls the number of scrolled lines

warning なので最悪使えるけど、邪魔すぎる。

対処法

alacritty.yml を編集する。
該当箇所をコメントアウトするか、普通に消す。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
scrolling:
# Maximum number of lines in the scrollback buffer.
# Specifying '0' will disable scrolling.
history: 10000

# Number of lines the viewport will move for every line scrolled when
# scrollback is enabled (history > 0).
# multiplier: 3 ここと

# Faux Scrolling
#
# The `faux_multiplier` setting controls the number of lines the terminal
# should scroll when the alternate screen buffer is active. This is used
# to allow mouse scrolling for applications like `man`.
#
# Specifying `0` will disable faux scrolling.
# faux_multiplier: 3 ここ

# Scroll to the bottom when new text is written to the terminal.
auto_scroll: false